Impossible de lancer JMRI

Rubrique dédiée aux applications JMRI.

Animateurs: Rodolphe, XTof_vl, Lionel

Impossible de lancer JMRI

Messagepar Jipe
12 Juin 2018, 18:00

Bonjour à tous.

Mon JMRI, que j'utilise depuis plusieurs années s'est mis à ne plus fonctionner, sans doute à la suite d'une manoeuvre ou d'un événement, mais je ne me souviens pas de quoi... Je précise que j'utilise une station LZV100 (niveau 3.6) et un boitier LIUSB.

J'ai effacé, nettoyé le registre, et réinstallé moultes fois l'appli avec la version la plus récente, mais, après un premier démarrage qui m'a permis de configurer les préférences (onglet connexion), plus moyen de la lancer ensuite.
J'ai réinstallé le driver Lenz, pensant que c'était le fautif. J'ai en même temps réinstallé les utilitaires Lenz. Avec le serveur LIUSB et l'utilitaire throttle ça fonctionne : je peux piloter une loco sur le réseau. On peut donc dire que la liaison USB/Com3 fonctionne, de même que l'échange XpressNet entre la centrale et le LIUSB.

Pourtant, toujours pas moyen de lancer JMRI. Je n'arrive à le démarrer qu'en débranchant le câble USB. Alors, je reparamètre la connexion dans la fenêtre préférences et je rebranche le câble. A Partir de ce moment, il faut un temps considérable pour accéder à une option dans un menu ou faire prendre en compte le moindre Clic. Si je lance un régulateur, l'indicateur de connexion est jaune et indique inconnu, preuve que JMRI ne voit pas la centrale.

Si j'arrête l'appli, il est de nouveau impossible de la relancer. J'ajoute que lorsque je procède au test Launchmanager, le compte-rendu m'indique que Java fonctionne correctement (c'est la version 1.8), mais que JMRI semble mal installé...

Une idée ?

Jipe, bien embêté.
Jipe
 
Messages: 149
Enregistré le: 14 Déc 2007, 10:29

Re: Impossible de lancer JMRI

Messagepar BURLINGTON
12 Juin 2018, 19:26

Pour pouvoir redémarrer JMRI lorsqu'il est planté, tu peux aller dans le gestionnaire des tâches de Windows et arrêter l’application.
Si ton JMRI est bugué, tu peux le désinstaller, télécharger à nouveau le logiciel et le réinstaller. Normalement tu ne perds pas tes enregistrements.
PREVOST Alain
Avatar de l’utilisateur
BURLINGTON
Riveteur de laiton
 
Messages: 3672
Âge: 64
Enregistré le: 13 Déc 2007, 22:40
Localisation: Au pays des lentilles AOC

Re: Impossible de lancer JMRI

Messagepar la frégate
12 Juin 2018, 19:55

il faut aussi vérifier que Java est à jour. J'ai cherché longtemps un jour et c'était tout simplement ça
a +
Avatar de l’utilisateur
la frégate
 
Messages: 691
Âge: 53
Enregistré le: 31 Aoû 2012, 18:31
Localisation: Houppeville (76)

Re: Impossible de lancer JMRI

Messagepar Jipe
12 Juin 2018, 22:43

C'est exactement ce que je fais. J'ai réinstallé les dernières versions de JMRI et de Java, j'ai sauvegardé toutes mes données avant d'effacer les répertoires après désinstallation, j'ai effacé toutes les entrées correspondantes dans le registre pour repartir avec une configuration vierge. J'ai fait tout cela au moins dix fois. Aucun résultat ....

Jipe
Jipe
 
Messages: 149
Enregistré le: 14 Déc 2007, 10:29

Re: Impossible de lancer JMRI

Messagepar BURLINGTON
12 Juin 2018, 22:57

As tu ces réglages dans le panneaux de préférences ?
PREVOST Alain
Avatar de l’utilisateur
BURLINGTON
Riveteur de laiton
 
Messages: 3672
Âge: 64
Enregistré le: 13 Déc 2007, 22:40
Localisation: Au pays des lentilles AOC

Re: Impossible de lancer JMRI

Messagepar Jipe
13 Juin 2018, 18:20

Après plusieurs manipulations, j'ai fini par obtenir toutes les coches dans les cases de cet onglet que tu montres (au début je n'avais que la command station). Mais ça ne m'avance pas pour le reste. Je n'accède toujours pas à l'interface.

En fouillant, j'ai fini par trouver une mise à jour pour la LI-USB si elle est utilisée avec une LZV version 3.6. J'ai désinstallé les pilotes et les programmes Lenz, j'ai installé les nouveaux (qui me semblent tout à fait identiques aux anciens), mais, au moment de lancer l'upgrade du firmware, pas moyen, un message m'informe qu'il n'a pas trouvé l'interface à upgrader, alors que le serveur LIUSB et l'utilitaire de configuration le trouve bien !

Je continue à chercher...

Jipe
Jipe
 
Messages: 149
Enregistré le: 14 Déc 2007, 10:29

Re: Impossible de lancer JMRI

Messagepar BURLINGTON
13 Juin 2018, 20:09

Sous quel Windows es tu :?:
PREVOST Alain
Avatar de l’utilisateur
BURLINGTON
Riveteur de laiton
 
Messages: 3672
Âge: 64
Enregistré le: 13 Déc 2007, 22:40
Localisation: Au pays des lentilles AOC

Re: Impossible de lancer JMRI

Messagepar alain355
13 Juin 2018, 20:47

Si ton windows c est XP ou Vista, l update Java maximum, c est la 8u151. Si tu installes une version plus récente de Java, JMRI ne demarre pas. J ai eu le pb sur le vieux PC sous XP du club.
Cf ici http://www.jmri.org/install/WindowsNew.shtml
Avatar de l’utilisateur
alain355
 
Messages: 252
Âge: 63
Enregistré le: 14 Déc 2007, 08:38
Localisation: Rueil Malmaison

Re: Impossible de lancer JMRI

Messagepar Jipe
13 Juin 2018, 22:39

Oui, mais je suis sous Win7 ...

Jipe
Jipe
 
Messages: 149
Enregistré le: 14 Déc 2007, 10:29

Re: Impossible de lancer JMRI

Messagepar alain355
14 Juin 2018, 09:12

Je ne saurais te dire: je suis sous Win10 perso. C'est sensé marché sous Win7. Ca ne coute pas grand chose néanmoins d'essayer avec l'update 151.

Autre idée: je n'ai pas vu indiqué ta version de JMRI......

Avec la "dernière version stable" 4.10, il y a un bug :mur: qui perturbe les connexions et les redéfinit de travers à Internal si JMRI pense avoir un pb....

As tu essayé avec la dernière version Test (4.11.6) qui corrige ce bug?
Modifié en dernier par alain355 le 14 Juin 2018, 09:27, modifié 1 fois.
Avatar de l’utilisateur
alain355
 
Messages: 252
Âge: 63
Enregistré le: 14 Déc 2007, 08:38
Localisation: Rueil Malmaison

Suivante

Retourner vers JMRI

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité