Nouvelle version 2.00 en avant première !

Rubrique dédiée au Centre de Programmation DCC

Animateur: ClaudeF

Re: Nouvelle version 2.00 en avant première !

Messagepar sncb_nmbs
13 Oct 2019, 19:44

Bonsoir,

PK204 a écrit:et ça tourne toujours pas sur Mac ??? :cry: :cry:




;)
"Il y a plus de bonheur à donner qu'à recevoir"
Avatar de l’utilisateur
sncb_nmbs
Bavard
 
Messages: 7788
Enregistré le: 25 Déc 2013, 11:29
Localisation: Carolo expatrié en hexagonage

Re: Nouvelle version 2.00 en avant première !

Messagepar JL28
14 Oct 2019, 11:53

J'ai installé la version 2 dans un autre répertoire, elle reconnait toute seule les anciens répertoires de l'ancienne version.
Voulant exécuter l'ancienne version, elle ne s'initialise pas, donc ouverture impossible.
J'ai voulu la réinstaller, mais impossible, ça me dit qu'il y a une version plus récente.
Désinstallation de la version 2. L'ancienne version ne marche toujours pas, et réinstallation impossible. Les 2 versions ne peuvent donc pas cohabiter.
Seule une restauration système à résolu le problème. Cette nouvelle version doit être encore finalisée je pense, car c'est un bon produit.
Membre AMFC Orléans
Avatar de l’utilisateur
JL28
 
Messages: 62
Enregistré le: 21 Jan 2019, 19:23

Re: Nouvelle version 2.00 en avant première !

Messagepar blrc45
14 Oct 2019, 22:03

Bonjour à tous,

Je cite ce que j'avais posté dans un autre message :

J'ai installée la version 2.0 Béta et sans désinstaller l'ancienne version 1.27 et à propos de la mutation des "chemins", primo cette install s'est déroulée sans aucun problème et de plus, à ma grande (très bonne) surprise, la V2.0 à repris intégralement les chemins où j'avais installés tous les fichiers nécessaires.

Je précise que je travaille avec deux micros différents et pour cette raison, j'ai choisi de placer tous ce qui est nécessaire (fiches locos, fichiers de définitions de décodeurs, fiches pdf, fichiers images des locos etc...) dans mon espace Dropbox pour être toujours synchronisé, c'est ce que j'avais fait avec V1.27 eh bien après install de la V2.0, celle-ci a repris intégralement tous les chemins vers mon Dropbox sans que je n'aie quoi que ce soit à faire ! Impeccable :cool: :applause:

Par contre pour l'instant j'ai un petit problème d'utilisation, j'ai cru un instant à un bug du programme mais non, en fait la faute à priori m'en incombe totalement, je pensais être sous le bon Framework.net mais je suis encore en fait sous la V4.0 donc charge à moi d'installer la V4.6 comme préconisé, ca sera pour demain et affaire à suivre, il se fait tard. ;) :dodo:


En fait, après quelques premiers tests, il subsiste encore quelques problèmes...

J'ai pu créer une fiche pour une nouvelle machine en interrogeant son décodeur, sa fiche xml est bien enregistrée, donc le logiciel semblerait fonctionner, à priori c'est ok de ce côté là.

Par contre impossible d'exporter sa fiche en PDF, j'ai un message d'erreur catégorique, (je ne l'ai pas capturé).

Par contre l'export en csv de la liste des fiches xml se passe bien.

Plus problématique, depuis la bibliothèque des fiches machines, je ne peux pas appeler une fiche machine, j'ai un message d'erreur :

Image


Ensuite le programme se ferme et rien de rien ca ne marche pas.

Ca signifie que après avoir créée la fiche xml d'une machine, on ne peut plus la rappeler depuis la bibliothèque et travailler dessus.

Est-ce que ca vient de mon ordi ou bug non résolu du DccCenter ?

En effet suivant la boite de dialogue ci-dessus, je m'étais dit que je n'avais pas le bon Framework donc téléchargement d'une V4.6 et tentative d'installation.

Mais message d'erreur comme quoi cette version existe déjà sur l'ordi :

Image


Donc après recherches, téléchargement d'une V4.6.1 et installation réussie d'après une boite de dialogue que je n'ai pas capturée car je pensais que c'était bon.

Mais le problème persiste concernant la tentative d'ouverture d'une fiche depuis la bibliothèque, même plantage et fermeture du DccCenter.

Dans le doute, j'avais recréés les chemins dans "Programdata\DccCenter et copiés tous les fichiers nécessaires là où il faut mais cela n'y a rien changé.

Après avoir fouillé dans "c:\Windows\Microsoft.NET\Framework (et Framework64), je n'y trouve pas réellement trace d'un dossier V4.6 ni V4.6.1


Image



Est-ce là le problème (sur mon ordi) ou bien un bug du logiciel à résoudre ?

En attendant, j'évite toute tentative d'écriture et/ou modifs sur un décodeur du moins si besoin j'ai la V1.27 toujours en place sur un autre ordi.

Est-il possible (maj ultérieure) d'avoir une "bulle d'aide" lors du survol à la souris de certaines icônes dans certains onglets ?

Voili-voilou pour l'instant,

Cordialement
Christian
Membre AMFC Orléans
Avatar de l’utilisateur
blrc45
 
Messages: 217
Âge: 65
Enregistré le: 25 Avr 2016, 00:23
Localisation: Loiret (Région Orléans)

Re: Nouvelle version 2.00 en avant première !

Messagepar ClaudeF
15 Oct 2019, 10:07

et ça tourne toujours pas sur Mac ??? :cry: :cry:


Eh non désolé ! Comme l'a très bien illustré sncb_nmbs : il y a un fossé entre les deux :mrgreen:

J'ai installé la version 2 dans un autre répertoire, elle reconnait toute seule les anciens répertoires de l'ancienne version.
Voulant exécuter l'ancienne version, elle ne s'initialise pas, donc ouverture impossible.
J'ai voulu la réinstaller, mais impossible, ça me dit qu'il y a une version plus récente.
Désinstallation de la version 2. L'ancienne version ne marche toujours pas, et réinstallation impossible. Les 2 versions ne peuvent donc pas cohabiter.
Seule une restauration système à résolu le problème. Cette nouvelle version doit être encore finalisée je pense, car c'est un bon produit.


:!: Attention ! Le passage de la version 1.27 à la 2 est un véritable "saut technologique" (pour utiliser une expression qui fait super sérieux) et il n'est pas possible de revenir en arrière si on installe la version 2. J'ai fait en sorte que le passage se passe bien de la 1.27 à la 2, mais pas l'inverse.

De même qu'il n'est pas prévu que les 2 versions cohabitent ! Il faut choisir son camp :mrgreen:

Plus problématique, depuis la bibliothèque des fiches machines, je ne peux pas appeler une fiche machine, j'ai un message d'erreur :


Pas de panique, cela vient probablement de l'application ! Le bug sera corrigé dans la version officielle 2.00. A priori votre ordinateur n'a pas de souci : le framework est bien installé (si l'application se lance c'est forcement qu'il est bien installé)
Avatar de l’utilisateur
ClaudeF
 
Messages: 453
Âge: 36
Enregistré le: 07 Mai 2012, 11:19

Re: Nouvelle version 2.00 en avant première !

Messagepar JL28
15 Oct 2019, 12:02

On ne va pas chipoter, c'est très bien ainsi, seul petit bémol, dans le haut de l'écran, l'image de la loco est
légèrement tronquée, ce n'est sûrement pas la version finale.
Membre AMFC Orléans
Avatar de l’utilisateur
JL28
 
Messages: 62
Enregistré le: 21 Jan 2019, 19:23

Re: Nouvelle version 2.00 en avant première !

Messagepar ClaudeF
15 Oct 2019, 14:18

On ne va pas chipoter, c'est très bien ainsi, seul petit bémol, dans le haut de l'écran, l'image de la loco est
légèrement tronquée, ce n'est sûrement pas la version finale.


Pourriez-vous m'envoyer une capture d'écran ? et la photo "non tronquée" pour que j'identifie clairement le problème.
Avatar de l’utilisateur
ClaudeF
 
Messages: 453
Âge: 36
Enregistré le: 07 Mai 2012, 11:19

Re: Nouvelle version 2.00 en avant première !

Messagepar JL28
15 Oct 2019, 17:22

Deux mails on été expédiés en début d'AM

@+ JL28
Membre AMFC Orléans
Avatar de l’utilisateur
JL28
 
Messages: 62
Enregistré le: 21 Jan 2019, 19:23

Re: Nouvelle version 2.00 en avant première !

Messagepar CHAMPALBERT
15 Oct 2019, 19:22

Bonjour,

En suivant les différentes contributions, j'ai voulu vérifier si j'étais dans le même cas que certain de mes confrères.

J'ai également des photos rognées dans la bandeau du haut de la fenêtre de l'affichage de la bibliothèque alors que l'image est entière sur la droite.

Plus curieux cette fenêtre de reboot clignotante qui se superpose à la liste des CV. Elle ne bloque pas le programme et aucun bouton ne permet de la fermer. Comment l'ai-je obtenue, c'est un mystère.

Je joints une copie d'écran.
Fichiers joints
CHAMPALBERT
 
Messages: 104
Enregistré le: 30 Avr 2013, 15:52

Re: Nouvelle version 2.00 en avant première !

Messagepar ClaudeF
16 Oct 2019, 08:54

@JL28 et @CHAMPALBERT merci pour vos retours respectifs, j'ai bien identifié le problème des images rognées et je vais corriger ça dès que possible :geek:

Concernant l'avertissement "reset" il est censé indiqué qu'il y a un CV de reset dans la liste : d'où le danger ! Si on envoie ce CV il va effectuer un RESET du décodeur. Mais dans votre cas, je ne vois pas pourquoi il apparaît. Pourriez-vous m'envoyer votre fiche locomotive ?
Avatar de l’utilisateur
ClaudeF
 
Messages: 453
Âge: 36
Enregistré le: 07 Mai 2012, 11:19

Re: Nouvelle version 2.00 en avant première !

Messagepar CHAMPALBERT
16 Oct 2019, 12:16

Bonjour

Le décodeur est un Lenz Plus classique, fiche loco jointe
Fichiers joints
BR 186.xml
Fiche Xml
(3.7 Kio) Téléchargé 36 fois
CHAMPALBERT
 
Messages: 104
Enregistré le: 30 Avr 2013, 15:52

PrécédenteSuivante

Retourner vers Centre de Programmation DCC

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités