Erreur avec le Sprog

Animateurs: Rodolphe, D2002

Erreur avec le Sprog

Messagepar jacques681
24 Aoû 2016, 12:02

Bonjour à tous.

Nouveau venu sur ce forum l'application My cube m'a beaucoup plus. Possédant tout le matériel necessaire je m'y suis lancé.
Après avoir tout installé j'ai un soucis de connexion avec mon Sprog3, il n'est pas reconnu et j'ai ce message:
erreur java.lang.nullpointerexception... :cry:
Là je sèche. Cela fait quelques heures que je suis entrain de tourner en rond...
J'utilise un pi2B+ un Sprog3 et me connecte en reseau via un pc.
Le Sprog fonctionne parfaitement avec decodeur pro.
Un soucis peut etre avec le port mais je trouve nul part ou le configurer, pas plus que je ne trouve de note dessus.

Une autre remarque que je voudrai faire c'est que pour un pur débutant comme moi qui veux commencer à utiliser My cube...... :oops: :oops: pas évident, car les tutaux ne sont pas classés à la suite et il faut mal fouiller pour les trouver.
Par exemple après le tuto 4 ou est le 5?....Après le 6 ou est le 7? Pour moi ll aurait pu etre plus simple de mettre un lien en bas de chaque page vers le tuto suivant ou précédent.
Maintenant c'est peut etre une volonté de la part des concepteurs pour tel ou tel raisons....

Sinon beau projet et très prometteur!! :D
jacques681
 
Messages: 7
Enregistré le: 20 Aoû 2016, 12:42

Re: Erreur avec le Sprog

Messagepar D2002
26 Aoû 2016, 13:40

Jacques,

Bonjour et bien venu au sein de la communauté.

D'après ta description ta configuration SPROG connecté sur Pi B2+ + PC connecté au Pi B2+ via Wifi (ou câble) me semble correcte. Pourrais-tu tout de même me confirmer la version que tu as installée ?

Afin que je puisse investiguer ton problème il faudrait que tu récupère les traces (logs) via le menu Administration et que tu me fasse parvenir le fichier (via MP ou en créant un incident via la page http://mytrain.fr/cms/index.php/com-issuetracker-admin-menu-issues/resolution-des-problemes/newissue).

Concernant la documentation, je suis conscient du fait que la navigation sur le site et à travers les différents tutos n'est pas simple. Je passe beaucoup de temps sur les développements, du coup la doc est la cinquième roue du carrosse que je néglige trop souvent.

Par contre je retiens ton idée de liens en bas de page.

A+
Image
Communauté MyTrain sur http://mytrain.fr. Pensez à vous inscrire.
Avatar de l’utilisateur
D2002
 
Messages: 197
Enregistré le: 18 Nov 2013, 11:01
Localisation: Plaisir (78)

Re: Erreur avec le Sprog

Messagepar jacques681
11 Sep 2016, 10:06

Bonjour

Je vois seulement ce jour ta réponse, (vacances obliges!!! :D )
Pour mon soucis pour l'instant j'ai laissé de coté My cube car j'utilise le raspi pour un autre projet, donc du coup j'en ai commandé un autre et dès réception je réinstalle le cube dessus et refais des tests! :)
jacques681
 
Messages: 7
Enregistré le: 20 Aoû 2016, 12:42

Re: Erreur avec le Sprog

Messagepar jacques681
13 Nov 2016, 12:25

Bonjour
J'ai enfin pu me remettre au projet mycube.
J'ai donc investi dans un autre "raspi", une version 3 avec wifi intégré.
Après installation j'arrive a me connecter sans soucis à l'interface mycube.
Mais je ne vais toujours pas pu loin le sprog n'étant pas reconnu..... :oops:
Ce qui est bizarre quand mème car à la mise en route de mycube il apparait comme étant détecté sur un port USB.
Mais quand je clique sur centrale, et que je veux passer l'onglet off sur on une petite fenêtre apparait connexion avec le module sprog , et ça tourne en rond avant de m'envoyer le message connexion impossible....... :evil:
voici le log:
!SESSION 2016-11-13 10:08:08.364 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_60
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=arm, WS=gtk, NL=en_GB
Command-line arguments: -console

!ENTRY org.eclipse.emf.ecore 2 0 2016-11-13 10:08:08.365
!MESSAGE Both 'org.d2002.mytrain.cube.dcc' and 'org.d2002.mytrain.cube.dcc' register a package for 'http://www.d2002.org/MYTRAIN/CUBE/DCC'

!ENTRY org.d2002.mytrain.core 0 0 2016-11-13 10:08:35.912
!MESSAGE Editing domain created in 1005 ms

!ENTRY org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.888
!MESSAGE Chargement des ressources (Chargement en 2966 ms)
!SUBENTRY 1 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.888
!MESSAGE Initialisation des préférences
!SUBENTRY 1 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Chargement ressources externes (2681 ressource chargées en 872 ms)
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Ouverture de la resource file:/root/d2002/database/resource/descritpor.xmi (Lecture de la resource)
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Lecture de la resource
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE 2681 ressource chargées en 872 ms
!SUBENTRY 1 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Chargement des containeurs (7 containeurs chargés en 1710 ms)
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Chargement containeur Centrales (Containeurs Centrales chargé en 31 ms)
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Ouverture de la resource file:/root/d2002/database/cube/CommandStations/folders.xmi (Lecture de la resource)
!SUBENTRY 4 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Lecture de la resource
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.889
!MESSAGE Containeurs Centrales chargé en 31 ms
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Chargement containeur Decodeurs DCC (Containeurs Decodeurs DCC chargé en 606 ms)
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Ouverture de la resource file:/root/d2002/database/cube/Decoders/folders.xmi (Lecture de la resource)
!SUBENTRY 4 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Lecture de la resource
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Containeurs Decodeurs DCC chargé en 606 ms
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Chargement containeur Camera (Containeurs Camera chargé en 3 ms)
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Ouverture de la resource file:/root/d2002/database/cube/Cameras/folders.xmi (Lecture de la resource)
!SUBENTRY 4 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Lecture de la resource
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Containeurs Camera chargé en 3 ms
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.890
!MESSAGE Chargement containeur SDMU (Containeurs SDMU chargé en 9 ms)
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Ouverture de la resource file:/root/d2002/database/cube/SDMUs/folders.xmi (Lecture de la resource)
!SUBENTRY 4 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Lecture de la resource
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Containeurs SDMU chargé en 9 ms
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Chargement containeur Cabine (Containeurs Cabine chargé en 953 ms)
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Ouverture de la resource file:/root/d2002/database/cube/Cabviews/folders.xmi (Lecture de la resource)
!SUBENTRY 4 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Lecture de la resource
!SUBENTRY 3 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Containeurs Cabine chargé en 953 ms
!SUBENTRY 2 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE 7 containeurs chargés en 1710 ms
!SUBENTRY 1 org.d2002.mytrain.core 1 0 2016-11-13 10:08:38.891
!MESSAGE Chargement en 2966 ms

!ENTRY org.d2002.mytrain.cube.sprog 1 0 2016-11-13 10:09:34.182
!MESSAGE Open SPROG using connector Socket 10.0.0.1:2002

!ENTRY org.d2002.mytrain.cube.sprog 1 0 2016-11-13 10:11:41.564
!MESSAGE Close SPROG connection

!ENTRY org.d2002.mytrain.cube.sprog 1 0 2016-11-13 10:11:41.640
!MESSAGE Close SPROG connection

Une idée???
jacques681
 
Messages: 7
Enregistré le: 20 Aoû 2016, 12:42

Re: Erreur avec le Sprog

Messagepar jacques681
13 Nov 2016, 12:53

Je poursuis mes investigations....
Je clique sur le bouton "+" ajout d’élément en bas à gauche pour rajouter la centrale sprog et quand je clique sur "on" je retombe sur mon erreur initiale "java.nullpointerexception"..... :mrgreen:
Bref toujours bloqué!!!
jacques681
 
Messages: 7
Enregistré le: 20 Aoû 2016, 12:42

Re: Erreur avec le Sprog

Messagepar D2002
21 Nov 2016, 20:20

Désolé mais je n'ai pas vu ton message avant.

Peux tu m'envoyer le fichier de log
Menu Administration > Gestion des logs > Export log Catalina.

Ton navigateur téléchargera alors un fichier catalina.out à m'envoyer (via MP)
Image
Communauté MyTrain sur http://mytrain.fr. Pensez à vous inscrire.
Avatar de l’utilisateur
D2002
 
Messages: 197
Enregistré le: 18 Nov 2013, 11:01
Localisation: Plaisir (78)


Retourner vers MyCube

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invités