DR4018 : problèmes de déprogrammation

Animateurs: Rodolphe, BR212

DR4018 : problèmes de déprogrammation

Messagepar Bahnfink
16 Mar 2018, 16:23

Bonjour de la part du Rail Model Club 04 à la MJC de Manosque.

Peut-être quelqu'un parmi vous pourrait nous sortir de l'embarras qui vient de la déprogrammation intempestive de nos décodeurs Digikeijs ?

Nous avons depuis plus d'un an 6 exemplaires DR 4018 qui commandent nos moteurs d'aiguillages PECO (HO), équipés pêle-mêle de bobines noires (gourmandes) et vertes (plus sobres).
L'alimentation des moteurs se fait en direct à la sortie des 4018. La centrale numérique est une ROCO 10830 Multi-Zentrale pro (la souris bleue) et la commande des itinéraires se fait sur TCO à l'écran, par le logiciel Roco dédié. En principe et par moments -trop rares-, les itinéraires se mettent en place, mais dans la plupart des cas, certaines aiguilles (mécanique très bon état) ne restent pas dans la position voulue, battent la chamade en grognant et reviennent dans la position initiale. Et qui plus est, ce phénomène va à chaque fois de pair avec la perte totale de la programmation des décodeurs.

Nos électriciens -dont un ancien cadre EDF- ont essayé bcp. de solutions sans tomber sur la bonne, pour l'instant.
Merci d'avance pour vos suggestions !
Infos complémentaires de notre part si besoin.
Bahnfink
 
Messages: 2
Enregistré le: 16 Mar 2018, 14:20

Re: DR4018 : problèmes de déprogrammation

Messagepar jc59
16 Mar 2018, 21:56

Bonsoir,

Le problème d'appel de courant pour les moteurs Peco est souvent évoqué ; cet appel est renforcé avec les aiguillages munis de ressorts de maintien un peu raides.
Certains ont adopté à cet effet des décodeurs à décharge capacitive.

Mais pour revenir à la question des 4018, vous pourriez faire un test sur une partie (si c'est possible) du reseau, et faire suivre d'un mini relais la sortie du 4018 et en prenant une alim externe. Le 4018 n'assurerait plus que la commande du relais. Ceci permettrait de vérifier si le pb vient de la surintensite demandée par les moteurs, ou même de surtension ou parasites créés par ceux-ci.

Désolé si mon message n'est pas très clair, j'écris ce mon message de mon lit de clinique et ne pourrait faire de tests ou de schemas en ce moment

Jean-Claude
jc59
 
Messages: 19
Enregistré le: 02 Fév 2018, 19:32

Re: DR4018 : problèmes de déprogrammation

Messagepar mermoz04
17 Mar 2018, 08:31

Bonjour,
Merci de votre aide.
Nous avons fait toutes les configurations possibles. Alimenté depuis la centrale ou alimenté depuis la centrale pour la commande et par un transfo Titan (1,2A) côté contacts des appareils. Nous avons introduit une constante de temps de 1 seconde entre chaque commande d'aiguillage lors du traçage des itinéraires...
... mais le sujet est identique lorsque l'on commande en direct avec la multimouse.
Élément :cry: important, nous avons vérifié tout notre câblage.
Et pour finir nous avons deux décodeurs pour lesquels des sorties de commande ont grillées, provoquant de surcroît la fonte de l'isolant des moteurs concernés par la commande. moteurs d'aiguillage qui ont du être remplacés.
Il est important que nous trouvions une solution car nous faisons la promotion et l'initiation aux techniques numériques. Il n'est pas envisageable de remplacer tous les appareils par des ROCO d'autant plus que l'on a "modernisé" récemment le périmètre avec des electrofrog.
J'ai longtemps suspecté un problème de retour de courant par les bobinages mais vu qu'il s'agit d'opto électronique ce ne devrait pas être le cas !
mermoz04
 
Messages: 5
Enregistré le: 15 Mar 2018, 17:09

Re: DR4018 : problèmes de déprogrammation

Messagepar BR212
17 Mar 2018, 16:25

Bonjour,
Comme le dit JC59 le problème des ressorts d’aiguille PECO est connue, moi qui suit en N, j’ai viré le ressort en le remplaçant par une fibre optique de 1 mm de diamètre ce qui assouplie bien le mouvement.
Mais ce qui m’inquiète le plus c’est la qualité erratique des mouvements qui vont du vibreur à la remise à l’état de départ ce qui ne devrai pas se produire.

A votre problème je voie bien un problème de fausse masse car ces décodeurs n’ont pas la masse communes mais le retour par le Plus commun et si vous avez des décharges capacitives basiques, j’ai bien peur que vous les aillez montés dans le mauvais sens ce qui a la mise sous tension de la sortie produit un court-circuit »localisé » ou une fuite de courant à la sortie sélectionnée.

Donc à votre problème je vois deux solutions possibles.

1. Installer des micros relais astables 12volt au 16 sorties du décodeur avec un transfo dédié aux aiguillages via le micro relais et une alimentation pour les décodeurs via un transfo ou la centrale le tout pour séparer les circuits.
2. Refaire des alimentations à décharge capacitives via des transistors qui permettrons un retour par le plot central »C » de chaque sortie d’aiguillage un petit lien:

http://www.ptitrain.com/electronique/te ... charge.htm

Perso ,j’ai la première solution ,mais par ce que mes moteurs d’aiguillages sont des relais automobiles modifiés.
BR212
 
Messages: 163
Enregistré le: 30 Juin 2016, 19:36

Re: DR4018 : problèmes de déprogrammation

Messagepar PhilHO95
18 Mar 2018, 19:28

mermoz04 a écrit:Bonjour,
Merci de votre aide.
Nous avons fait toutes les configurations possibles. Alimenté depuis la centrale ou alimenté depuis la centrale pour la commande et par un transfo Titan (1,2A) côté contacts des appareils. Nous avons introduit une constante de temps de 1 seconde entre chaque commande d'aiguillage lors du traçage des itinéraires...
... mais le sujet est identique lorsque l'on commande en direct avec la multimouse.
Élément :cry: important, nous avons vérifié tout notre câblage.
Et pour finir nous avons deux décodeurs pour lesquels des sorties de commande ont grillées, provoquant de surcroît la fonte de l'isolant des moteurs concernés par la commande. moteurs d'aiguillage qui ont du être remplacés.
Il est important que nous trouvions une solution car nous faisons la promotion et l'initiation aux techniques numériques. Il n'est pas envisageable de remplacer tous les appareils par des ROCO d'autant plus que l'on a "modernisé" récemment le périmètre avec des electrofrog.
J'ai longtemps suspecté un problème de retour de courant par les bobinages mais vu qu'il s'agit d'opto électronique ce ne devrait pas être le cas !


Depuis quand il y a de l'opto-électronique dans les décodeur ?
Quand bien même, depuis quand l'opto-électronique tiendrait mieux les sur-tension que l'électronique ?

Pour avoir essayé de mettre en place des décodeurs pour alimenter des moteurs PECO (PL10 et PL10W) à mon club, j'en ai gardé pour expérience que c'est une chose extrêmement difficile du fait de la demande excessive en énergie de ces moteurs:

Donc, premier conseil, si l'on en est encore au point de choisir un moteur: pas de PECO PL10(W) pour le numérique.
(PS: meme si le moteur PECO est le moins cher, au final l'ensemble moteur + décodeur + alim + inverseur si aiguille electrofrog sera le plus cher)
Deuxième conseil, si le réseau est déjà équipé de moteur PL10, à ma connaissance, il n'y a que le décodeur LENZ LS150 + tres gros transfo qui peut convenir, d’après les discussion sur les forum (j'ai jamais essayé):
http://forum.e-train.fr/viewtopic.php?t=58037

Enfin, si vous avez déjà acheter le moteur et le décodeur, il y a peut-être une petite chance de remédier au problème en vérifiant la configuration du décodeur et en utilisant une alim séparée.
a) alimentation: un transfo de 18V/3A sur l'entrée "power", la centrale sur l'entrée "signal" (voir schéma page 25 de la notice)
b) Verifer la programmation du decodeur: les sorties ne doivent en aucun cas etre actives en continu. Il faut qu'elles génèrent une impulse de 0,1 à 1 seconde maximum.
il faut configurer le CV47 (preset) à 13, les CV 113 à 128 = 7, les CV 238 à 253 = "valeur" entre 0 et 255 qui soit suffisante pour "bouger" l'aiguille, mais pas trop pour éviter tout rebond.

Enfin, si cela ne marche toujours, comme indiqué dans les réponses précédentes, il faudra intercalé entre les sorties du décodeur et les bobines du moteur une interface qui soit capable de fournir la puissance nécessaire:
- soit un relais (un relais par bobine du fait qu'il faut juste une impulsion)
- soit un module à décharge capacitive.
http://www.ptitrain.com/electronique/te ... charge.htm
Montages PACO: NanoX88, Minimaus2b, RS2PC, Unisem648, Dcc4servo, servopoint, dbAcc4,
Club: centrale LENZ LZV100, ROCO z21, Digikeijs DR5000, DR5033, Train Controler Gold V8
PhilHO95
 
Messages: 284
Enregistré le: 22 Avr 2016, 13:46

Re: DR4018 : problèmes de déprogrammation

Messagepar mermoz04
21 Mar 2018, 22:43

Bonsoir,
Le réseau du club est en code 100 Peco et, comme ailleurs, même s'il a fait l'objet d'un entretien et de rénovations au fil de l'eau, la plupart de nos appareils de voies et itinéraires sont commandés par décharges capacitives, poussoirs , sélection d'itinéraire par grille de diodes pour les itinéraires et relais. (www.chez.com/railmc04)
Ça c'est la partie désormais plus ancienne.
Pour la rénovation de notre "grande gare" l'option a été de replacer cette technologie par des décodeurs numériques, les appareils ayant un commun différent du reste des installations
Parmi les réponses apportées via le forum, je vais tester le raccordement "isolé" du commun de chaque aiguillage, sur le plot C des sorties de décodeur.
Si le retour du + se fait effectivement tel qu'expliqué, cela devrait apporter une solution.
Si cette solution ne fonctionne pas, nous aurons plus qu'à envisager de mettre un relai intermédiaire et une alimentation des appareils de voie depuis une décharge capacitive.

Toutes les autres solutions suggérées au travers du forum ont été testées !
Il faut être pris pour être appris !
A titre personnel je n'ai pas eu ce problème sur mon réseau où, de façon homogène, tout est en Roco (appareils décodeurs,télécommande).
Ce qui n'est pas sympa, c'est que nous avons sollicité le fabricant par mail avec un message en Français et en Allemand et celui-ci est resté aux abonnés absents.

Je vous tiendrai informé des essais à venir .
Cordialement
mermoz04
 
Messages: 5
Enregistré le: 15 Mar 2018, 17:09

Re: DR4018 : problèmes de déprogrammation

Messagepar mermoz04
23 Mar 2018, 22:13

Bonsoir.

Et bien voilà j’ai trouvé l’os qui nous ennuyait depuis bientôt un an.
Les propositions reçues par le Forum de LR m’ont permis de constater une communion d’esprit sur le sujet et les difficultés.

Finalement soit je les avaient déjà testées, soit elles me semblaient trop complexes par rapport au Digital .
Ainsi si la solution de doubler la commande par des relais intermédiaires me semblait techniquement intéressante, c’était pour moi la solution du « désespoir ». On repartait à refaire des plaquettes de composants comme il y a vingt ans.

Finalement j’ai trouvé la « panne » un peu par hasard.

J’ai isolé le « commun » d’un des appareils du commun général propre aux appareils commandés par décodeurs.

En voulant raccorder le commun et le fil de chacune des bobines, j’ai choisi une sortie qui nous avait posée problème.
Il c’est avéré que sur cette sortie (11 ; C ; 12 par exemple), le point de raccordement 11 était alimenté en permanence.
J’ai retrouvé ce défaut sur deux autres sorties de deux autres décodeurs.
J’ai aussi pu constater qu’il suffisait de connecter un plot « c » du décodeur pour que tous les autres plots C du même décodeur soient alimentés !
Finit les petit « strap » à deux balles.

Dans les faits je ne peux pas assurer que les défaillances constatées soient un défaut d’origine.
En effet, lors des premiers mois de fonctionnement, comme j’ai pu l’indiquer, plusieurs moteurs ont été grillés.
Je n’ai pas souvenir si c’était sur les sorties en question ou si les défauts existaient avant.
Ces incidents ont peut être dégradés les commandes en question.

Bref, les trois commandes en question ont été isolées et par mesure de précaution.
Le raccordement du commun au décodeur se fait sur un point « C » distinct de ceux des sorties défaillantes.
Il semble que le fait de ne plus faire de "strap" de commun en commun ait un impact sur les commandes défaillantes puisque les défauts ont disparu en même temps. Les commandes défaillantes présentant une borne alimentée en permanence (vu avec le testeur).

J’ai pu tester cette après midi divers itinéraires et les commandes ne se sont plus « déprogrammées ».
Il faudra voir dans le temps si cela n’occasionne pas la fonte de quelques autres moteurs d’aiguillage.
Nous devrons quand même remplacer les quelques moteurs « noirs» par des « verts » moins exigeants en énergie.

Bon, Ouf, depuis trois mois, j’avais vraiment envie de lâcher tout et de partir faire du vélo .

Michel :dodo:
mermoz04
 
Messages: 5
Enregistré le: 15 Mar 2018, 17:09

Re: DR4018 : problèmes de déprogrammation

Messagepar PhilHO95
24 Mar 2018, 11:11

Le fait qu'une sortie soit alimentée en permanence n'est pas une indication de défaillance mais plutôt d'une mauvaise programmation:
Vu que ce décodeur est aussi fait pour commander des signaux, il est normale que les sorties puissent être alimentées en continu.
Pour le verifier , il suffit d'actionner les 2 sorties (11 et 12) par la centrale (droit / dévié) et de vérifier que l'alimentation continue bascule bien de C-11 a C-12.
Montages PACO: NanoX88, Minimaus2b, RS2PC, Unisem648, Dcc4servo, servopoint, dbAcc4,
Club: centrale LENZ LZV100, ROCO z21, Digikeijs DR5000, DR5033, Train Controler Gold V8
PhilHO95
 
Messages: 284
Enregistré le: 22 Avr 2016, 13:46

Re: DR4018 : problèmes de déprogrammation

Messagepar mermoz04
25 Mar 2018, 10:08

Je vais vérifier ce paramètre car, même si le fonctionnement est redevenu normal, il n'y a aucune explication rationnelle hormis un défaut sur le décodeur ( lié ou non à un problème de sur tension suite à la fonte de bobinage des moteurs d'aiguille.
J'avais déjà fait une réinitialisation du décodeur sans succès.
Belle journée
mermoz04
 
Messages: 5
Enregistré le: 15 Mar 2018, 17:09

Re: DR4018 : problèmes de déprogrammation

Messagepar mermoz04
26 Mar 2018, 18:27

Bonsoir,
J'ai fais un contrôle des décodeurs en testant les sorties "défaillantes" comme proposé dans le dernier échange du forum, histoire de voir s'il s'agissait d'une programmation de type interrupteur pour les signaux.

Il s'avère que la borne défaillante d'une commande ( exp : 11) reste alimentée lorsque l'on déclenche la commande de l'autre borne ( exp 12 ) de la même commande.
A cet instant les deux bornes (11 ; 12 ) donne du courant au moment où on l'actionne via la multimouse.
C'est pas bien bon et antinomique et cela peut expliquer les moteurs "fondus" et une déprogrammation par augmentation exagéré de l'intensité durant un court instant !!!

Il y a donc bien une avarie sur une sortie de commande de trois décodeurs.

Enfin, de toute façon la procédure que j'ai mise en place dans mon échange précédent, fonctionne, et c'est bien là l'essentiel. :siffle:

Merci à tous

Michel
mermoz04
 
Messages: 5
Enregistré le: 15 Mar 2018, 17:09


Retourner vers Digikeijs

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité